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Report Writing: Basic Steps  
Working with Reports 
The Research Wizard allows you to create multi-company reports that 
combine Zacks database items and your own calculated items. The 
Research Wizard also includes several sample reports.  The reports have 
extension *.rpd and are located in the :\zir\inputs folder. 

Creating New Reports 
There are two ways to create a report in the Research Wizard. You can 
display items used in your screening definition, or you can select items for 
your portfolio (Ticker List). When you build the screen definitions in the 
Research Wizard, the screening criteria items are automatically added to the 
Report Definition table. By default, the report will always include the 
Company Name and the Ticker items.    

In order to run a report, you must have the Screening Criteria defined first.   
The Screening Criteria could be a screen definition or a portfolio. 

Creating Reports for Existing Portfolio 
To create a report for the existing Ticker List, follow these steps: 

1. From the Portfolio menu, select the Open Ticker List command or click 
the Open Ticker List button and choose your Ticker List. 

2. The Screening Criteria table will show the Ticker List name and the 
number of companies in it. 

3. To add a database item to your report, select that item from the Items
section and click the Add Item to Report button (or from the Report
menu choose the Add Database Item command).   

4. The added item will appear in the Report Definition table.   

5. To save the report for future uses, select the Save Report Definition 
command from the Report menu. 

6. The Report Definition dialog box will appear and the default folder for the 
report files will be shown (usually :\zir\inputs). To save the file in a 
different folder, click a different drive in the Save in box, or double-click a 
different folder in the folder list. 

7. In the File name box, type a name for the report (all reports have 
extension *.rpd). 

8. Click Save.

Tip To add an item to your report with the mouse, highlight that item in the Items
section and right-click your mouse. Select the Add Database Item to Report
command from the menu. 

Adding Multi-Period Data Items 

When adding items that have more then one period associated with them, 
the Report Column dialog box has a special check box: History. This option 
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allows you to add multiple data periods at once. After marking the History 
check box, simply select the desired time periods and click OK.

Add several periods of data at once by selecting the History  
check box  on the Report Column menu. 

To align data by the same period, you can specify your selection  as period 
#1, #2, etc.  

Editing Report Definitions 
One way to modify a report is to add a new item to the report definition.  The 
other option is to manipulate the existing items. 

Adding Items to Report 
To add an item to the report, follow these steps: 

1. Open the report definition you want to edit. The Report Definition table 
will fill up. 

2. Highlight a new item from the Items section.  

3. From the Report menu, select the Add Database Item command or click 
the Add Database Item button. 

4. The item will be added to the Report Definition table. 

5. Save your report definition. 

Tip To add an item with the mouse, highlight that item in the Items section and
right-click your mouse. Select the Add Database Item to Report command
from the menu. 

Editing Report Definitions Overview 
To edit the report, from the Report menu, select the Edit Report Definition 
command to display the following report editing options:  
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� Modify – changes report column’s name, alignment, format, time 
period and calculation. 

� Cut – removes the selected item from the Report Definition table and 
places it on the Clipboard.   

� Copy – copies the selected report item to the Clipboard.  

� Paste – inserts the item currently placed on the Clipboard at the 
insertion point in the Report Definition table, and replaces any 
selection. This command is available only if you have cut or copied a 
report item.  

� Delete  – permanently removes the item from the Report Definition
table. 

� Insert – puts in the item currently placed on the Clipboard between 
the items at the insertion point in the Report Definition table. This 
command is available only if you have cut or copied a report item.  

Tip To get the edit menu in the Report Definition table, right-click your mouse
inside the Report Definition table. 

By default, you report definition will always have Ticker and Company items. 
These items cannot be deleted.   

Modify Report  Overview  
Some options on the Modify menu are available for all types of items.  These 
options include Column Name, Alignment, and Column Format. 

Other options become enabled when the item used in a report has more then 
one data period or is a calculated item. These options are Time Period and 
Calculation.  

To aid in your work, the database name and the item's number (or a 
calculation expression) are also noted at the Modify Column dialog box. 

Modify Column options will depend on the item. 

Column Name � used to change the item’s name.  If the item’s name is long, 
you can use two lines for the name. 

Alignment � used to change the item’s position within the column.  By 
default, all items are Right Justified.   

Column Format � used to change the way numbers are displayed (the first 
format shown on the list is the default format).   



24 ��  Report Writing: Basic Steps Research Wizard 4.0 

� Numbers Format: columns can be formatted to display numbers with 
zero, one, or more decimal places and use the 1000 separator (,).  You 
can also apply currency, percent, and comma styles to the numbers.   

      The following table explains the column formats: 

Input     Format   Result 
21366.8457 #0 21367 
21366.8457 #0.0 21366.8 

21366.8457 #0.00 21366.85 
21366.8457 #0.000 21366.846 

21366.8457 #0.0000 21366.8457 
21366.8457 #,##0 21,367 

21366.8457 #,##0.0 21,366.8 
21366.8457 #,##0.00 21,366.85 

21366.8457 #,##0.000 21,366.846 
21366.8457 #,##0.0000 21,366.8457 

21366.8457 $#,##0  $21,367 
21366.8457 $#,##0.0 $21,366.8 

21366.8457 $#,##0.00 $21,366.85 
1.839 #0% 2% 

1.839 #0.0% 1.8% 
1.839 #0.00% 1.84% 

� Text Capitalization Format: there are three additional column 
format options, available for the text items:  

  Format   Result 
Text(Upper)  UPPERCASE
Text(Lower) lowercase
Text(Default) Title Case 

Time Period � used to change item’s period (available for time-series items 
only).   

Calculation � used to change the calculation for the custom item 
(Calculation Expression). 

Modify (Edit Report Menu) 

The report item can be a database item or a calculated item.  This will
determine the additional edit options. 

Modifying Database Item  

1. Open the report definition you want to edit. The Report Definition table 
will fill up. 

2. From the Report Definition table, highlight the item you want to modify 
and double-click it (or right-click your mouse on that item to bring up the 
Edit menu and select the Modify option). The Modify Column dialog box 
will appear, where item number and database association are noted. 
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3. Modify the parameters for your report and click OK.

Modifying Calculated Item 

1. Open the report definition you want to edit. The Report Definition table 
will fill up. 

2. From the Report Definition table, highlight the calculated item you want 
to modify and double-click it (or right-click your mouse on that item to 
bring up the Edit menu and select the Modify option). The Modify Column
dialog box will appear, where item formula will be noted. 

3. Click the Calculation button (if the calculation expression was build 
using database that is not currently active, you will be prompted to switch 
to that database). The Calculation Expression dialog box will appear. 
Make the necessary changes there and click OK.

Cut (Edit Report Menu)  

To cut a report item, follow these steps:  

1. Open the report definition you want to edit.  The Report Definition table 
will fill up. 

2. Highlight the data item you want to cut. 



26 ��  Report Writing: Basic Steps Research Wizard 4.0 

3. From the Report menu, select the Edit Report Definition command and 
select the Cut option. You can then paste or insert the item anywhere in 
the report definition (except for two default items: Ticker and Company). 

Tip To get the Edit menu in the Report Definition table, right-click your mouse
inside the Report Definition table. 

Copy (Edit Report Menu) 

To copy a report item, follow these steps:  

1. Open the report definition you want to edit.  The Report Definition table 
will fill up. 

2. Highlight the data item you want to copy. 

3. From the Report menu, select the Edit Report Definition command and 
select the Copy option. (If you want to copy these items to another report 
definition, switch to that report). 

4. In the Report Definition table, click where you want the item to appear.  

5. To replace the item, from the Report menu, select the Edit Report 
Definition command and select the Paste option.  

6. To add the item, from the Report menu, select the Edit Report Definition 
command and select the Insert option.  

Tip To get the Edit menu in the Report Definition table, right-click your mouse
inside the Report Definition table. 

Paste (Edit Report Menu) 

This command is available only if you have cut or copied a report item.  In 
the Report Definition table, highlight the item you want to replace. From the 
Report menu, click Edit Report Definition command and select the Paste 
option.  

Tip To get the Edit menu in the Report Definition table, right-click your mouse
inside the Report Definition table. 

Delete (Edit Report Menu) 

To delete a report item, follow these steps:  

1. Open the report definition you want to edit.  The Report Definition table 
will fill up. 

2. Highlight the item you want to delete.  

3. From the Report menu, select the Edit Report Definition command and 
select the Delete option.   

Tip To get the Edit menu in the Report Definition table, right-click your mouse
inside the Report Definition table. 

Insert (Edit Report Menu)  
This command is available only if you have cut or copied a report item.  In 
the Report Definition table, click where you want the item to appear.  To 
add the item to the report, from the Report menu, click Edit Report Definition 
command and select the Insert option.  

Tip To get the Edit menu in the Report Definition table, right-click your mouse
inside the Report Definition table.



Research Wizard 4.0  Report Writing: Basic Steps �� 27  

Clearing Report Definition  
To Clear both Screening Criteria and Report Definition 
Tables 
1. From the Screen menu, select the Clear Criteria command or click the 

Clear Criteria button. 

2. The message “Would you like to clear the Report Definition?” will appear.  
Click Yes.

3. Both the Screening Criteria and the Report Definition tables will be 
emptied. 

To Clear the Repot Definition Table Only 
1. From the Report menu, select the Clear Report Definition command. 

2. The Report Definition table will be emptied. 

Sorting and Organizing Reports 
You can manipulate the information displayed in your reports using the Sort 
and Organize options.  These features are accessed through the Data menu.  

Organize/Sort Report dialog box. 

By default, all new reports are sorted by Zacks M (Medium) Industry. 

Organize Report Options 
An Organize option is used to classify companies in the report.  Your report 
can be organized by 

� Zacks X (Expanded) Industry 

� Zacks X (Expanded) Sector 

� Zacks (M) Medium Aggregate Industry 

There are two more special options that allow two levels of organization:  

� Organize by Zacks Expanded Sector and then by Expanded Industry 
designations 
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� Organize by Zacks Expanded Sector and then by Medium Aggregate 
Industry designations    

If you do not want to have your report organized, select None from the pull-
down menu. 

Organizing Reports 
You can organize your reports before or after you run them.  To organize a 
report, follow these steps: 

1. From the Data menu, select the Organize/Sort command or click the 
Organize/Sort button.  The Organize/Sort dialog box will be displayed. 

2. From the Organize by pull-down menu, choose the desired organize 
option and click OK.

3. After organizing the report, you will be able to sort on up to three 
additional items.  If you selected two levels of organization, you will be 
able to sort on up to two additional items. 

Sorting Reports 
You can sort your reports based on the contents of two or more columns.  
When you sort, the Research Wizard rearranges the report based on the sort 
order you specify. You can sort reports in ascending (1 to 9, A to Z) or 
descending (9 to 1, Z to A) order, based on the contents of one or more 
columns.  

To sort the report, follow these steps:

1. From the Data menu, select the Organize/Sort command or click the 
Organize/Sort button.  The Organize/Sort dialog box will be displayed. 

2. Select the first sorting item in the Sort by box and the sort order – 
ascending or descending.  

3. If the column you specify in the Sort by box has items that have identical 
values for several companies (example, Zacks Rank of 1), you can sort 
the values further by specifying another column in the first Then By box. 
If there are duplicate items in the second column, you can specify a third 
column to sort by in the second Then By box (the Research Wizard 
allows for sort on up to four items). 

4. Click OK.

Running Existing Reports 
To run an existing report, follow these steps: 

1. From the Report menu, select the Open Report Definition command. 
The Report Definition dialog box will appear. (Saved reports usually 
appear in :\zir\inputs folder and have extension  *.rpd). 

2. Select a report and click OK. The Report Definition table will fill up. 

3. Click Run Query to display the report.   

The Research Wizard has several sample pre-formatted reports. 
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Adding/Removing Indices Options in Reports 
By default, every report includes data for S&P 500, S&P Industrial, and DJIA 
Indices at the top of the report. You can add or remove these indices, by 
clicking Indices from the report output Data menu.  

Adding Titles to Reports 
To add title to your report, type the desired name in the provided report Title 
section at the report output menu (remember to save the report definition). 


